J2SE 5.0 リリース4

 なんてのがソフトウェア・アップデートよりリリースされております。

J2SE(Java 2 Standard Edition)5.0 リリース 4 により、Mac OS X v10.4.5 以上での Java 2 Platform Standard Edition 5.0 の信頼性と互換性が改善されます。このリリースには、 J2SE バージョン 1.5.0_06 が含まれています。アップデートにより、Java 1.4.2 に代わって J2SE 5.0 が優先される Java バージョンになります。Java 1.4.2 はコンピュータにインストールされたままですが、アプリケーションが Java 1.4.2 を特にリクエストしないかぎり、J2SE 5.0 を使用してアプリケーションは実行されます。
 っつう事ですから、逆にXcodeからちゃんと1.4系へ向ける様に設定してあげればWebObjectsをお使いの向きにも適用可能なんじゃないかな。……試してないし、試す気もないけど。

ーー追記ーー
 Mac OS X 10.4.5 or later: J2SE 5.0 Release 4 アップデートをインストール後の、Java の問題(アップル)

 Java 1.4.2 への戻し方。

ーー追記: '06/04/22ーー
 J2SE 5.0 Release 4 Release Notes